BTCPay Server Maintenance and Updates

Completed
Scheduled for May 10, 2023 at 9:00 AM – 11:00 AM

Affects

BTCPay Servers
btcpay0
btcpayA
btcpayb
btcpayc
Updates
  • Completed
    May 10, 2023 at 11:00 AM
    Completed
    May 10, 2023 at 11:00 AM

    Maintenance has completed successfully

  • In progress
    May 10, 2023 at 9:00 AM
    In progress
    May 10, 2023 at 9:00 AM

    Maintenance is now in progress

  • Planned
    May 10, 2023 at 9:00 AM
    Planned
    May 10, 2023 at 9:00 AM

    We are performing scheduled maintenance on all BTCPay Server instances. During this time the servers will be offline. The BTCPay servers will also be updated to the latest version during this maintenance.